Albert OpenCL and VMware Fusion not doing well together

Thomas Bauer
Thomas Bauer
Joined: 26 Feb 12
Posts: 1
Credit: 4,368,921
RAC: 0
Topic 84829

From my limited experience with Albert@Home, GPU units and VMware Fusion VMs that have "Accelerated 3D Graphics" set to "On" do NOT get along.

Once I start such a VM while BOINC is using the GPU (or start a GPU based unit while such a VM is powered on):
1. The display fails to update other than the mouse moving (but clicking does nothing).
2. The only way to interact with the system is via SSH
3. While connected via SSH, I can kill any process except for the "einsteinbinary_BRP4_1.22_i686-apple-darwin__atiOpenCLLion" process (even if I use "sudo kill -9 "; all other boinc sub processes stop with a kill -3 ).
4. The system has to be forced off ("sudo shutdown -h" doesn't work because the "einsteinbinary_BRP4_1.22_i686-apple-darwin__atiOpenCLLion" never ends.

System Information:
iMac Mid 2011
3.4GHz Intel Core i7
16GB RAM
AMD Radeon HD 6970M 2048MB
Mac OS X Lion 10.7.3 (11D50)
VMware Fusion 4.1.0

BOINC 7.0.18 (x86-apple-darwin)
wxWidgets 2.8.10
libcurl/7.21.7 OpenSSL/0.9.7l zlib/1.2.5 c-ares/1.7.4
Processor: 8 GenuineIntel Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz [x86 Family 6 Model 42 Stepping 7]
Processor features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM PBE SSE3 PCLMULQDQ DTES64 MON DSCPL VMX SMX EST TM2 SSSE3 CX16 TPR PDCM SSE4.1 SSE4.2 xAPIC POPCNT AES PCID XSAVE OSXSAVE TSCTMR AVX1.0
OpenCL: ATI GPU 0: ATI Radeon HD 6970M (driver version 1.0, device version OpenCL 1.1, 1024MB, 1024MB available)